TestNamespace Namespace

CollapseAll image | DropDown image
C#

Visual Basic

Visual C++

TestNamespace Namespace
[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Syntax

C# | Visual Basic | Visual C++
namespace TestNamespace
Namespace TestNamespace
namespace TestNamespace

Types

All Types | Classes Public class
Name Description
Public class StoredNumber
Tests whether sandcastle can handle all c# tags as defined at http://msdn2.microsoft.com/en-us/library/5ast78ax.aspx. Comments of method "Increment (int step)" include almost all tags. Method "Swap" is used to test generics tags, such as "typeparam".

Thread Safety

Static members of this type are safe for multi-threaded operations. Instance members of this type are not safe for multi-threaded operations.

Send comments about this topic to Microsoft.


StoredNumber Class

| Members | See Also
StoredNumber Class
[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Tests whether sandcastle can handle all c# tags as defined at http://msdn2.microsoft.com/en-us/library/5ast78ax.aspx. Comments of method "Increment (int step)" include almost all tags. Method "Swap" is used to test generics tags, such as "typeparam".

Thread Safety

Static members of this type are safe for multi-threaded operations. Instance members of this type are not safe for multi-threaded operations.

Namespace: TestNamespace
Assembly: test (in test.dll)

Syntax

C# | Visual Basic | Visual C++
[SerializableAttribute]
public class StoredNumber
<SerializableAttribute> _
Public Class StoredNumber
[SerializableAttribute]
public ref class StoredNumber

Members

All Members | Constructors Public method | Properties Public property | Methods Public method
Public

Protected
Instance

Static Static member
Declared

Inherited
XNA Framework Only Supported by the XNA Framework

.NET Compact Framework Only Supported by the .NET Compact Framework

Member | Description
Public method StoredNumberStoredNumberNew(Int32)
Initializes the stored number class with a starting value.
Public method | Dec()()
Public method Dec(Int32)
dec by a specified step
Public method Equals(Object)
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize()()
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode()()
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType()()
Gets the Type of the current instance.
(Inherited from Object.)
Public method Increment()()
Increment method incriments the stored number by one.
Note Note: note description here
This API is preliminary and subject to change.
Public method Increment(Int32)
Increment method incriments the stored number by a specified step.
  1. Item 1.
  2. Item 2.

see Int32

seealso System..::Int64

Protected method MemberwiseClone()()
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public property MyProp
Gets or sets a Brush used to fill the area between the borders of a InkCanvas. see nullNothingnullptr as reference
Public method | PreliminaryTest()()
Public method Swap<(Of <T>)>(T%, T%)

The element type to swap

Swap data of type T

Public method ToString()()
Returns a String that represents the current Object.
(Inherited from Object.)
Public property Value
Gets the stored number.

Inheritance Hierarchy

System..::Object
TestNamespace..::StoredNumber

See Also

TestNamespace Namespace


StoredNumber Constructor

| See Also
StoredNumber Constructor
[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes the stored number class with a starting value.

Namespace: TestNamespace
Assembly: test (in test.dll)

Syntax

C# | Visual Basic | Visual C++
public StoredNumber(
    int value
)
Public Sub New ( _
    value As Integer _
)
public:
StoredNumber (
    int value
)

Parameters

value
Int32

See Also

StoredNumber Class


StoredNumber Methods

StoredNumber Methods
[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Syntax

C# | Visual Basic | Visual C++
[SerializableAttribute]
public class StoredNumber
<SerializableAttribute> _
Public Class StoredNumber
[SerializableAttribute]
public ref class StoredNumber

The type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Public method | Dec()()
Public method Dec(Int32)
dec by a specified step
Public method Equals(Object)
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize()()
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode()()
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType()()
Gets the Type of the current instance.
(Inherited from Object.)
Public method Increment()()
Increment method incriments the stored number by one.
Note Note: note description here
This API is preliminary and subject to change.
Public method Increment(Int32)
Increment method incriments the stored number by a specified step.
  1. Item 1.
  2. Item 2.

see Int32

seealso System..::Int64

Protected method MemberwiseClone()()
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method | PreliminaryTest()()
Public method Swap<(Of <T>)>(T%, T%)

The element type to swap

Swap data of type T

Public method ToString()()
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

TestNamespace Namespace

Send comments about this topic to Microsoft.


StoredNumber.Dec Method

| | See Also
StoredNumber..::Dec Method
[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

test overlads tag

Overload List

Name | Description
Dec()() |
Dec(Int32) | dec by a specified step

See Also


StoredNumber.Dec Method

StoredNumber..::Dec Method
[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: TestNamespace
Assembly: test (in test.dll)

Syntax

C# | Visual Basic | Visual C++
public void Dec()
Public Sub Dec
public:
void Dec ()

See Also


StoredNumber.Dec Method (Int32)

StoredNumber..::Dec Method (Int32)
[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

dec by a specified step

Namespace: TestNamespace
Assembly: test (in test.dll)

Syntax

C# | Visual Basic | Visual C++
public void Dec(
    int step
)
Public Sub Dec ( _
    step As Integer _
)
public:
void Dec (
    int step
)

Parameters

step
Int32

See Also


StoredNumber.Increment Method

| | See Also
StoredNumber..::Increment Method
[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name Description
Increment()()
Increment method incriments the stored number by one.
Note Note: note description here
This API is preliminary and subject to change.
Increment(Int32)
Increment method incriments the stored number by a specified step.
  1. Item 1.
  2. Item 2.

see Int32

seealso System..::Int64

See Also


StoredNumber.Increment Method

StoredNumber..::Increment Method
[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Increment method incriments the stored number by one.
Note Note: note description here
This API is preliminary and subject to change.

Namespace: TestNamespace
Assembly: test (in test.dll)

Syntax

C# | Visual Basic | Visual C++
public void Increment()
Public Sub Increment
public:
void Increment ()

See Also


StoredNumber.Increment Method (Int32)

| Example | See Also
StoredNumber..::Increment Method (Int32)
[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Increment method incriments the stored number by a specified step.
  1. Item 1.
  2. Item 2.

see Int32

seealso System..::Int64

Namespace: TestNamespace
Assembly: test (in test.dll)

Syntax

C# | Visual Basic | Visual C++
public void Increment(
    int step
)
Public Sub Increment ( _
    step As Integer _
)
public:
void Increment (
    int step
)

Parameters

step
Int32
specified step

Field Value

The Name property gets/sets the _name data member.

Return Value

Returns nothing

Remarks

You may have some additional information about this class.

Examples

This sample shows how to call the GetZero method.
Copy image Copy Code
             class TestClass
             {
                 static int Main()
                 {
                     return GetZero();
                 }
             }

Permissions

Permission | Description
System.Security..::PermissionSet | Everyone can access this method.

Exceptions

Exception | Condition
System..::Exception | Thrown when...

See Also


StoredNumber.PreliminaryTest Method

StoredNumber..::PreliminaryTest Method
[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This API is preliminary and subject to change.

Namespace: TestNamespace
Assembly: test (in test.dll)

Syntax

C# | Visual Basic | Visual C++
public void PreliminaryTest()
Public Sub PreliminaryTest
public:
void PreliminaryTest ()

See Also


StoredNumber.Swap Generic Method

StoredNumber..::Swap<(Of <T>)> Method
[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The element type to swap

Swap data of type T

Namespace: TestNamespace
Assembly: test (in test.dll)

Syntax

C# | Visual Basic | Visual C++
public void Swap<T>(
    ref T lhs,
    ref T rhs
)
Public Sub Swap(Of T) ( _
    ByRef lhs As T, _
    ByRef rhs As T _
)
public:
generic<typename T>
void Swap (
    T% lhs,
    T% rhs
)

Parameters

lhs
T%
rhs
T%

Type Parameters

T

See Also


StoredNumber Properties

StoredNumber Properties
[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Syntax

C# | Visual Basic | Visual C++
[SerializableAttribute]
public class StoredNumber
<SerializableAttribute> _
Public Class StoredNumber
[SerializableAttribute]
public ref class StoredNumber

The type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

 | Member | Description
Public property | MyProp | Gets or sets a Brush used to fill the area between the borders of a InkCanvas. see nullNothingnullptr as reference
Public property | Value | Gets the stored number.

See Also

TestNamespace Namespace

Send comments about this topic to Microsoft.


StoredNumber.MyProp Property

StoredNumber..::MyProp Property
[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets a Brush used to fill the area between the borders of a InkCanvas. see nullNothingnullptr as reference

Namespace: TestNamespace
Assembly: test (in test.dll)

Syntax

C# | Visual Basic | Visual C++
public int MyProp{ get; set;}
Public Property MyProp As Integer
public:
property int MyProp {
    int get ();
    void set (int value);
}

See Also


StoredNumber.Value Property

StoredNumber..::Value Property
[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the stored number.

Namespace: TestNamespace
Assembly: test (in test.dll)

Syntax

C# | Visual Basic | Visual C++
public int Value{ get;}
Public ReadOnly Property Value As Integer
public:
property int Value {
    int get ();
}

See Also