TestNamespace Namespace
CollapseAll image
[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Syntax

C#
namespace TestNamespace
Visual Basic (Declaration)
Namespace TestNamespace
Visual C++
namespace TestNamespace

Classes

Class Description
Public class StoredNumber
Tests whether sandcastle can handle all c# tags as defined at http://msdn2.microsoft.com/en-us/library/5ast78ax.aspx. Comments of method "Increment (int step)" include almost all tags. Method "Swap" is used to test generics tags, such as "typeparam".

Thread Safety

Static members of this type are safe for multi-threaded operations. Instance members of this type are not safe for multi-threaded operations.

Send comments about this topic to Microsoft.


StoredNumber Class
See Also Members
CollapseAll image DropDown image

[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Tests whether sandcastle can handle all c# tags as defined at http://msdn2.microsoft.com/en-us/library/5ast78ax.aspx. Comments of method "Increment (int step)" include almost all tags. Method "Swap" is used to test generics tags, such as "typeparam".

Thread Safety

Static members of this type are safe for multi-threaded operations. Instance members of this type are not safe for multi-threaded operations.

Namespace: TestNamespace
Assembly: test (in test.dll)

Syntax

C#
[SerializableAttribute]
public class StoredNumber
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class StoredNumber
Visual C++
[SerializableAttribute]
public ref class StoredNumber

Inheritance Hierarchy

System..::Object
TestNamespace..::StoredNumber

See Also

StoredNumber Members
TestNamespace Namespace


StoredNumber Members
See Also Methods Constructors Properties
CollapseAll image DropDown image

[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Syntax

C#
[SerializableAttribute]
public class StoredNumber
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class StoredNumber
Visual C++
[SerializableAttribute]
public ref class StoredNumber

The type exposes the following members.

Public Constructors

 | Name | Description
Public method | StoredNumberStoredNumberNew | Initializes the stored number class with a starting value.

Public Methods

 | Name | Description
Public method | Dec | Overloaded. test overlads tag
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Increment | Overloaded.
Public method | PreliminaryTest |
Public method | Swap<(Of <T>)> | The element type to swap Swap data of type T
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

Public Properties

 | Name | Description
Public property | MyProp | Gets or sets a Brush used to fill the area between the borders of a InkCanvas. see nullNothingnullptr as reference
Public property | Value | Gets the stored number.

See Also

StoredNumber


StoredNumber Constructor
See Also
CollapseAll image DropDown image

[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes the stored number class with a starting value.

Namespace: TestNamespace
Assembly: test (in test.dll)

Syntax

C#
public StoredNumber(
    int value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Integer _
)
Visual C++
public:
StoredNumber (
    int value
)

Parameters

value
Int32

See Also

StoredNumber Class


StoredNumber Methods
CollapseAll image DropDown image

[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Syntax

C#
[SerializableAttribute]
public class StoredNumber
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class StoredNumber
Visual C++
[SerializableAttribute]
public ref class StoredNumber

The type exposes the following methods.

Public Methods

 | Name | Description
Public method | Dec | Overloaded. test overlads tag
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Increment | Overloaded.
Public method | PreliminaryTest |
Public method | Swap<(Of <T>)> | The element type to swap Swap data of type T
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Protected Methods

 | Name | Description
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)

See Also

StoredNumber


Dec Method

StoredNumber..::Dec Method
See Also Members
CollapseAll image
[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

test overlads tag

Overload List

 | Name | Description
Public method | Dec()() |
Public method | Dec(Int32) | dec by a specified step

See Also

StoredNumber Members


Dec Method

StoredNumber..::Dec Method
CollapseAll image DropDown image

[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: TestNamespace
Assembly: test (in test.dll)

Syntax

C#
public void Dec()
Visual Basic (Declaration)
Public Sub Dec
Visual C++
public:
void Dec ()

See Also


Dec Method (Int32)

StoredNumber..::Dec Method (Int32)
See Also
CollapseAll image DropDown image

[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

dec by a specified step

Namespace: TestNamespace
Assembly: test (in test.dll)

Syntax

C#
public void Dec(
    int step
)
Visual Basic (Declaration)
Public Sub Dec ( _
    step As Integer _
)
Visual C++
public:
void Dec (
    int step
)

Parameters

step
Int32

See Also


Increment Method

StoredNumber..::Increment Method
See Also Members
CollapseAll image
[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name Description
Public method Increment()()
Increment method incriments the stored number by one.
Note Note: note description here
This API is preliminary and subject to change.
Public method Increment(Int32)
Increment method incriments the stored number by a specified step.
  1. Item 1.
  2. Item 2.

see Int32

seealso System..::Int64

See Also

StoredNumber Members


Increment Method

StoredNumber..::Increment Method
CollapseAll image DropDown image

[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Increment method incriments the stored number by one.
Note Note: note description here
This API is preliminary and subject to change.

Namespace: TestNamespace
Assembly: test (in test.dll)

Syntax

C#
public void Increment()
Visual Basic (Declaration)
Public Sub Increment
Visual C++
public:
void Increment ()

See Also


Increment Method (Int32)

StoredNumber..::Increment Method (Int32)
See Also Example
CollapseAll image DropDown image

[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Increment method incriments the stored number by a specified step.
  1. Item 1.
  2. Item 2.

see Int32

seealso System..::Int64

Namespace: TestNamespace
Assembly: test (in test.dll)

Syntax

C#
public void Increment(
    int step
)
Visual Basic (Declaration)
Public Sub Increment ( _
    step As Integer _
)
Visual C++
public:
void Increment (
    int step
)

Parameters

step
Int32
specified step

Field Value

The Name property gets/sets the _name data member.

Return Value

Returns nothing

Remarks

You may have some additional information about this class.

Examples

This sample shows how to call the GetZero method.
Copy image Copy Code
             class TestClass
             {
                 static int Main()
                 {
                     return GetZero();
                 }
             }

Permissions

Permission | Description
System.Security..::PermissionSet | Everyone can access this method.

Exceptions

Exception | Condition
System..::Exception | Thrown when...

See Also


PreliminaryTest Method

StoredNumber..::PreliminaryTest Method
CollapseAll image DropDown image

[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This API is preliminary and subject to change.

Namespace: TestNamespace
Assembly: test (in test.dll)

Syntax

C#
public void PreliminaryTest()
Visual Basic (Declaration)
Public Sub PreliminaryTest
Visual C++
public:
void PreliminaryTest ()

See Also


Swap Generic Method

StoredNumber..::Swap<(Of <T>)> Method
CollapseAll image DropDown image

[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The element type to swap

Swap data of type T

Namespace: TestNamespace
Assembly: test (in test.dll)

Syntax

C#
public void Swap<T>(
    ref T lhs,
    ref T rhs
)
Visual Basic (Declaration)
Public Sub Swap(Of T) ( _
    ByRef lhs As T, _
    ByRef rhs As T _
)
Visual C++
public:
generic<typename T>
void Swap (
    T% lhs,
    T% rhs
)

Parameters

lhs
T%
rhs
T%

Type Parameters

T

See Also


StoredNumber Properties
CollapseAll image DropDown image

[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Syntax

C#
[SerializableAttribute]
public class StoredNumber
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class StoredNumber
Visual C++
[SerializableAttribute]
public ref class StoredNumber

The type exposes the following properties.

Public Properties

 | Name | Description
Public property | MyProp | Gets or sets a Brush used to fill the area between the borders of a InkCanvas. see nullNothingnullptr as reference
Public property | Value | Gets the stored number.

See Also

StoredNumber


MyProp Property

StoredNumber..::MyProp Property
CollapseAll image DropDown image

[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets a Brush used to fill the area between the borders of a InkCanvas. see nullNothingnullptr as reference

Namespace: TestNamespace
Assembly: test (in test.dll)

Syntax

C#
public int MyProp{ get; set;}
Visual Basic (Declaration)
Public Property MyProp As Integer
Visual C++
public:
property int MyProp {
    int get ();
    void set (int value);
}

See Also


Value Property

StoredNumber..::Value Property
CollapseAll image DropDown image

[This topic is pre-release documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the stored number.

Namespace: TestNamespace
Assembly: test (in test.dll)

Syntax

C#
public int Value{ get;}
Visual Basic (Declaration)
Public ReadOnly Property Value As Integer
Visual C++
public:
property int Value {
    int get ();
}

See Also